Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DLL Talk / Rainbow gui editor problems

Author
Message
paul5147
13
Years of Service
User Offline
Joined: 11th Jan 2006
Location: Hot & Sunny
Posted: 16th Oct 2008 21:30
Im having a few problems with the rainbow editor for blue gui,am i right in thinking that it uses blue gui for its own interface and if so then how come what i design isnt what i get.Im running it on vista as a compiled source and it seems to be using the vista styles ok for all the buttons and windows and such like, but the exported code it gives me , when run in my application allways comes out with a flat grey style , its as if its not exporting the styles correctly,ive tried loading the rainbow source code and with a bit of editng i can get it to compile in u6.9 but i get the same bug the editor uses vista styles correctly but not the exported source,everthing comes out looking like windows 98,help
Ian G
10
Years of Service
User Offline
Joined: 3rd Jun 2008
Location: SSM, Canada
Posted: 17th Oct 2008 02:03
Did you include the manifest file in the root of your exe? Copy it out of [DBP Dir]/BlueGUI Extras/myapp.exe.manifest and rename the manifest to your exe name.
paul5147
13
Years of Service
User Offline
Joined: 11th Jan 2006
Location: Hot & Sunny
Posted: 17th Oct 2008 13:16
Yes the manifest file is there,it gets copied automaticaly if you use the rainbow project creator,is there anything in it that needs changing or is it the same foe every app.It might just be me but i cant get my head around why rainbow using its own DLL should get all the vista\xp styles even while designing your layout,but when you come to run your app from the editor its just plain old grey? Is there anything else that should be in the route folder of the project,when you run project creator there is a box to tick if you want xp styles but it doesnt seem to make any difference to the files that are copied or exported by rainbow.
Ian G
10
Years of Service
User Offline
Joined: 3rd Jun 2008
Location: SSM, Canada
Posted: 17th Oct 2008 23:43 Edited at: 17th Oct 2008 23:49
I'll have a look, but I don't really know what could be the problem. I don't have vista to see what is going on but I'll see what I can do.

[Edit]
If you make a program from scratch, do Vista styles appear?
paul5147
13
Years of Service
User Offline
Joined: 11th Jan 2006
Location: Hot & Sunny
Posted: 19th Oct 2008 14:15 Edited at: 19th Oct 2008 14:33
Still having no luck with this,even making the interface from scratch and not using the project creator or rainbow,i still only get a flat grey interface,begining to wonder if this is just a vista problem but i dont have an xp system to try this on any more, allthough i seem to remember getting the 3d button effect to work on xp,i dont even get that with vista.Any one know what the allowable style parameters are with the commands in blue as the help only lists 0 for a 3D button, 1 for a flat button and even that doesnt make any difference to the appearance on my system

another minor problem,is it possible to have more than one line of text on a button,or does it simply try to centre all text?
tiresius
16
Years of Service
User Offline
Joined: 13th Nov 2002
Location: MA USA
Posted: 24th Oct 2008 18:41
Does the rainbow editor come with source? Perhaps you could compare the editor source with the code it produces and see what's different. It really does sound like a manifest file but you tried that already...

I'm not a real programmer but I play one with DBPro!
Pixel Paint
11
Years of Service
User Offline
Joined: 15th Sep 2007
Location:
Posted: 25th Oct 2008 16:05
I know the manifest file works with XP, but Vista....
Ian G
10
Years of Service
User Offline
Joined: 3rd Jun 2008
Location: SSM, Canada
Posted: 26th Oct 2008 00:46
I just don't understand why rainbow works - it is DBP code with the same manifest file.

paul5147:

Even though you used the project creator, did you change the output exe name? The manifest file must share the same name as the exe. By default, project.exe and project.exe.manifest are created, but if either names changed, the manifest won't work. That's the only thing that I could think of to be causing the problem.
paul5147
13
Years of Service
User Offline
Joined: 11th Jan 2006
Location: Hot & Sunny
Posted: 31st Oct 2008 16:20
No Ian G,i kept the names the same,i even tried making the interface from scratch and just copying the manifest file in to the project folder and renaming it to match,nothing seems to work.
the version of rainbow im using is the compiled version from the original download as the latest version i cant get to compile due to plugin\variable name conflicts.
EDIT
Ive resolved all the conflicts by removing the offending dll\keywords file but i still cant get the newer version of rainbow to compile, it just flashes up the windows then shuts down without any error codes ?
MayoZebraHat 1979
11
Years of Service
User Offline
Joined: 21st Dec 2007
Location:
Posted: 7th Dec 2008 10:58 Edited at: 7th Dec 2008 11:03
I've not had much luck with version 1.04. The only change I've made is put my id and key in so it will actually compile. I have yet to look much at the source code but I know that right out of the box it doesn't load your work (I did think It wasn't saving, but I can load it in 1.02 after creating in 1.04), I'll be hunting that bug down. I'm interested in adding functionality. If I make big progress I will share. Also, Null$ will conflict with the function in Matrix1Util_04 Commands.
paul5147
13
Years of Service
User Offline
Joined: 11th Jan 2006
Location: Hot & Sunny
Posted: 8th Dec 2008 18:55
Yes,thats the offending dll Mayo i just moved it out of folder and started the editor again,ive had similar problems with the file loading/saving but i cured that buy turning off the user account control in vista,and left it off when i found out that the editor (BlueIDE) wasnt saving my backups either,if your default directory is on the c drive in program files then vista blocks all atempts to save to it with out any errors being displayed.Just what you want after 6 hours coding and a crash!!!!!!!
MayoZebraHat 1979
11
Years of Service
User Offline
Joined: 21st Dec 2007
Location:
Posted: 9th Dec 2008 08:29 Edited at: 9th Dec 2008 08:44
I didn't want to displace any plug-ins so I just changed null$ to nul$. I did email Robert though I doubt he has much time to answer. I'm still trying to debug things so maybe I can help with solutions.

I'm using XP but I still have the strange problem with it not loading all the items with the 1.04 source. It will load menus but that's all. Also, I found the v1.00 source and it does that closing right after you open the .exe that you talked about. The 1.04 is the only other source I can find and it works fine except for loading .gui files. For some reason it seems like when it's parsing a .gui for words the strings go null somewhere but I can't find the offending code... I'll try again later.

I wish I had vista to help with your problem as well but I don't have that. http://msdn.microsoft.com/en-us/library/bb756929.aspx has some info on the UAC options in vista manifest files but I doubt that gives you any help. Also, what happens when you use the enableXPStyles on gadgets in your code? I would hate to think that you have to include that for each gadget...
Blobby 101
12
Years of Service
User Offline
Joined: 17th Jun 2006
Location: England, UK
Posted: 14th Dec 2008 21:36
I think the manifest file only works with XP. I'm not sure, but I've heard that somewhere. If that is the case, then i don't think theres a lot you can do.

Caleb1994
10
Years of Service
User Offline
Joined: 10th Oct 2008
Location: The Internet you idiot!
Posted: 10th Apr 2009 01:37
Whats Rainbow GUI?

New Site! Check it out \/
tiresius
16
Years of Service
User Offline
Joined: 13th Nov 2002
Location: MA USA
Posted: 10th Apr 2009 06:05
Holy bump, batman!

Rainbow editor is a DBPro program using Blue GUI where you can build forms visually and it will spit out DBPro code to build the forms using Blue GUI. I've never used it personally but that's what it is.

I'm not a real programmer but I play one with DBPro!
Caleb1994
10
Years of Service
User Offline
Joined: 10th Oct 2008
Location: The Internet you idiot!
Posted: 10th Apr 2009 20:19
Quote: "Holy bump, batman!
"


it's holy rusted metal batman lol


on topic:

oh ok sweet thanks i had never herd of it

New Site! Check it out \/

Login to post a reply

Server time is: 2019-04-23 06:00:40
Your offset time is: 2019-04-23 06:00:40