Why is it that people continue to insist on using meaningless numbers for their getstate values, when DirectX provides a much more readable and self-documenting format?
if (dbKeyState(DIK_W))
{
//Move forward.
}
if (dbKeyState(DIK_S))
{
//Move backward.
}
if (dbKeyState(DIK_A))
{
//Go Left.
}
if (dbKeyState(DIK_D))
{
//Go right.
}
Make it easy on yourselves - make it so your code is readable, not only today, but in six months time. Don't use 'magic numbers' - use constants or defines:
for (int i = 0; i < 100; ++i) { } // 100 What?
const int MaxEnemies = 100;
for (int i = 0; i < MaxEnemies; ++i) { } // Loop through all enemies
... sorry, one of my pet peeves