The conventional way for using constants is defining it as a constant:
rem Current Action
#constant Casting = 1
#constant Swinging = 2
#constant Damaged = 3
#constant Trapped = 4
It's also much cleaner to have all of the = in the same row, makes it easier to read. Same goes for things like UDTs:
rem General
Type BaseObj
xpos as integer
ypos as integer
zpos as integer
CurrSpeed as integer
Alive as boolean
objRect as Rect
ObjNum as integer
endtype
The compiler doesn't care how many spaces you have between commands, so you are able to do that. Also get in the habit of defining variables at the top of your program. Nothing is worse than using variables that aren't defined:
rem global variables ---------------------
rem general
global bla as word
global GiveMeDaCodez as BOOK
global banana as integer
And keep everything commented as much as possible. Good commenting is half of the code.
TheComet