Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / Getting this linker error for T2

Author
Message
ManOfActionTM
11
Years of Service
User Offline
Joined: 16th May 2011
Location: Sahuarita, Arizona
Posted: 5th Jan 2012 17:48
Undefined symbols:
"AGK::agk:latformDestroyGL()", referenced from:
AGK::agk:estroyGL() in libAGKiOS.a(Wrapper.o)
ld: symbol(s) not found

I haven't added any of my code yet, just trying to make the default template run.
bjadams
AGK Backer
14
Years of Service
User Offline
Joined: 29th Mar 2008
Location:
Posted: 6th Jan 2012 17:08
you are compiling to the emulator.

the errors don't happen when compiling to a real ios device.

tgc will fix this problem soon, if they haven't already done so in the latest update
ManOfActionTM
11
Years of Service
User Offline
Joined: 16th May 2011
Location: Sahuarita, Arizona
Posted: 6th Jan 2012 17:11
Thanks for answering!

So do I just plug in my iPad or iPhone to the mac in the meantime?
bjadams
AGK Backer
14
Years of Service
User Offline
Joined: 29th Mar 2008
Location:
Posted: 6th Jan 2012 18:48
yes, just compile to a real device.

also, are you sure you have the very latest update ?
ManOfActionTM
11
Years of Service
User Offline
Joined: 16th May 2011
Location: Sahuarita, Arizona
Posted: 6th Jan 2012 18:52
The latest version for Mac I can download from my account is v1054 from October.

Do I need the iOS interpreter w/ AdMob from Aug. 30 as well? Or is that just for Ads?
bjadams
AGK Backer
14
Years of Service
User Offline
Joined: 29th Mar 2008
Location:
Posted: 8th Jan 2012 17:03
no
you need to download the pc version
unarchive it
and copy the relevant folders over to your mac to get the latest v106

Login to post a reply

Server time is: 2022-10-04 10:07:10
Your offset time is: 2022-10-04 10:07:10