Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / obj/local/armeabi/ failed issue

Joshua A
User Offline
Joined: 19th Feb 2012
Posted: 27th Feb 2012 20:17
What does this error mean

Cygwin : Generating dependency file converter script
Compile arm : android_player <= main.c
Compile++ arm : android_player <= Core.cpp
Compile++ arm : android_player <= interpreter.cpp
Prebuilt : libAGKAndroid.a <= jni/armeabi/
Compile thumb : android_native_app_glue <= android_native_app_glue.c
StaticLibrary : libandroid_native_app_glue.a
StaticLibrary : libstdc++.a
SharedLibrary :
/cygdrive/c/android/android-ndk-r7b/build/core/ recipe for target `obj/local/armeabi/' failed

i get it every time I compile the android_Interpreter file with cygdrive
User Offline
Joined: 8th Feb 2012
Posted: 5th Mar 2012 15:12
I would really much like to know this as well.

I dont have a signature...
User Offline
Joined: 30th Nov 2010
Location: Poland
Posted: 5th Mar 2012 18:31
This means you've got some error in the source code. Open up log.txt (I guess you're adding 2> log.txt at the end of compile code line)

then paste it's contents here.

User Offline
Joined: 8th Feb 2012
Posted: 6th Mar 2012 11:30
That's the text I get when I open the generated Log.txt-file.

I dont have a signature...
User Offline
Joined: 3rd Jan 2012
Posted: 10th Mar 2012 21:45
Similar problem here. Mine says this:
+ Code Snippet


Login to view attachments
User Offline
Joined: 3rd Jan 2012
Posted: 11th Mar 2012 17:34
This is a stupid solution, however, I solved my problem by downgrading to NDK-r6b, running Cygwin in Admin mode (win7), and giving full control permissions to all the project files (namely libAGKAndroid.a). This method, however, doesn't work with NDK r7b.

Official link to r6b:
User Offline
Joined: 1st Mar 2007
Location: In my world
Posted: 14th Mar 2012 09:34
Nope, actually it's because of Win7's stupid way of dealing with attributes, setting your files to read-only! Had this problem when compiling T2 for Android, I fixed it by reinstalling AGK in drive D:/E: and copying all my files to C:/Android from there.
Daniel TGC
TGC Support
User Offline
Joined: 19th Feb 2007
Location: TGC
Posted: 26th Mar 2012 19:42
cygwin is a linux command prompt for Windows, this means you can adjus file permissions using the linux command CHMOD the line I used to fix this issue was:

chmod -R 777 /cygdrive/c/Android/AGK

This basically removes any security restrictions from those files, that were applied when they were originally written to the C:\Program files\ folder.

-R ensures all the secuity settings are removed, 777 is the specific file permission setting I'm sure any web authors will recognise it, and the rest is just the path name. I recommend performing this operation on the AGK folder only.

Login to post a reply

Server time is: 2015-10-09 21:45:22
Your offset time is: 2015-10-09 21:45:22