Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

FPSC Classic Product Chat / Viral Outbreak (Mp52) - Issues Reported and Fixed

Author
Message
Flatlander
FPSC Tool Maker
12
Years of Service
User Offline
Joined: 22nd Jan 2007
Location: The Flatlands
Posted: 5th Apr 2012 04:17 Edited at: 2nd May 2013 15:46
If anybody found issues with this model pack, it is not because of v1.19 but with the scripts.

Three characters seem to freeze when killed. These characters are:

1. Decayed,
2. Grendel, and
3. Pincher


Here is how to fix the scripts. We'll start with Decayed.

Decayed


Open the script viral_outbreak\decayed_main.fpi. Notice the first eight lines:



Place a semi-colon before the line that starts with :healthless=150. It should look like this: ;:healthless=150. For now I would not suggest deleting this line; although, it is not needed as far as I can tell.

Do the same with the file viral_outbreak\decayed2_main.fpi, viral_outbreak\decayedtwicher_main.fpi, and viral_outbreak\decayedtwicher2_main.fpi

Now we need to revise the script viral_outbreak\decayed_destroy.fpi. Open this script and delete or comment out the lines that are currently present within the script and then add this script line.




Grendel

Open the script viral_outbreak\Grendel_main.fpi. Notice the first eight lines:



Place a semi-colon before the line that starts with :healthless=150. It should look like this: ;:healthless=150. For now I would not suggest deleting this line; although, it is not needed as far as I can tell.

Do the same with the file viral_outbreak\Grendel2_main.fpi.

Now we need to revise or create, like I had to do, the script viral_outbreak\grendel_destroy.fpi. Open this script and delete or comment out the lines that are currently present within the script and then add this script line.



Or you may have to actually create a new script that is called "grendel_destroy.fpi." Here is the script:



Name it grendel_destroy.fpi and place it in the "scriptbank\viral_outbreak" folder.

Pincher

Open the script viral_outbreak\pincher1_main.fpi. Notice the first eight lines:



Place a semi-colon before the line that starts with :healthless=200. It should then look like this: ;:healthless=200. For now I would not suggest deleting this line; although, it is not needed as far as I can tell.

Next we need to go to the last line. If you are using FPI EditPad, it should be line #71. Notice the very last action command, ",sethealth=300". Delete this. The total line should now look like this:



Now we need to revise the script viral_outbreak\pincher_destroy.fpi. Open this script and delete or comment out the lines that are currently present within the script and then add this script line.



Addendum:

The Medusa character's main script (both of them) has a line that contains an error. It isn't crucial and only seems to prevent a sound effect from occurring.

The line is



A colon is required after "frameatend=23." It should then look like this:



However, this does not fix if the Medusa freezes up after a kill. For some reason this happened after re-checking the characters for v1.20 beta 17. I do not know exactly why or when this issue started to show up.

My personal fix was to re-download and then re-install this pack. Either save and copy the other characters scripts -- not Medusa's script -- or fix the scripts after re-installing the pack. For some reason Medusa worked again. I then fixed the line as mentioned above.


I'm addicted to programming and coffee!
KeithC
Senior Moderator
13
Years of Service
User Offline
Joined: 27th Oct 2005
Location: Michigan
Posted: 5th Apr 2012 05:06
Pinned for now.

-Keith

BlackFox
FPSC Master
10
Years of Service
User Offline
Joined: 5th May 2008
Location: Knight to Queens Bishop 3
Posted: 5th Apr 2012 05:14
Thank you for taking the time to solve this issue, Flatlander. It is greatly appreciated.

Thank you, KeithC, for pinning so others can find this with ease (hopefully LOL).


Twitter: @NFoxMedia
Scene Commander
Support Manager
10
Years of Service
User Offline
Joined: 3rd May 2008
Location:
Posted: 5th Apr 2012 10:13
Good work on this Flatlander, I'm sure it's very much appreciated by many users.
Leongamerz
8
Years of Service
User Offline
Joined: 14th Aug 2010
Location:
Posted: 5th Apr 2012 14:14
Thanks for helping us,Flatlander.Really appreciate it.

Irradic,Poloflece,Anayar,PWP,Henry Ham,Cosmic Prophet,Wolf,KeithC,Nickydude,SceneCommander,Dark Goblin And Lee Bamber is my icon.

GreenDixy
10
Years of Service
User Offline
Joined: 24th Jul 2008
Location: Toronto
Posted: 7th Apr 2012 10:58 Edited at: 7th Apr 2012 11:24
Edit: Works great thank you it also fixed other problem.

======================================
My software never has bugs. It just develops random features.
maho76
7
Years of Service
User Offline
Joined: 31st May 2011
Location: universe-hub, playing the flute
Posted: 9th Apr 2012 03:52
thanks for this.

mnemonic
12
Years of Service
User Offline
Joined: 14th Jan 2007
Location: Sweden
Posted: 9th Apr 2012 12:44
Good job! Thanks

www.memblockgames.com
Burger
6
Years of Service
User Offline
Joined: 22nd Jun 2012
Location: New Zealand
Posted: 30th Jun 2012 02:50
I'm not sure if anyone will reply or if this is where to post, but I've recently bought this model pack and some of the characters just dont match the video. The Medusa has black stuff all over it and has no firey death. Also some of the characters dont have glowing eyes. Am I doing something wrong? Check the pic attached.

That's right, I'm Mr T.

Attachments

Login to view attachments
The Zombie Killer
8
Years of Service
User Offline
Joined: 27th Mar 2011
Location: Gold Coast, Australia
Posted: 30th Jun 2012 10:34
@Burger
It's probably looking like that because the editor doesn't use shaders, I wouldn't know though, because I don't own that pack.
Can we see an in-game shot? If it looks like that in-game, then make sure you have shader effects set to "Full Shader Effects" in preferences. If you cannot handle shaders, then you can't use viral outbreak properly

-TZK

Shakleford
FPSC Reloaded TGC Backer
8
Years of Service
User Offline
Joined: 15th Jun 2010
Location: on the flip side
Posted: 30th Jun 2012 18:42
Well thats how they should look in the editor, also the other monsters wont habe glowing eyes in the editor.

That being said, like TZK mentioned, if they look like that in-game, then make sure u have "full shader effects" turned on in prefernces.

The tragedy of old age is not that one is old, but that one is young
Burger
6
Years of Service
User Offline
Joined: 22nd Jun 2012
Location: New Zealand
Posted: 1st Jul 2012 02:28
I am using full shader effects and have been all this time really. I didn't mention it but I have tested all of the creatures ingame. Heres a shot of the medusa ingame, it looks the same as in the editor. My computer is definitely good enough to handle shaders.

That's right, I'm Mr T.

Attachments

Login to view attachments
The Zombie Killer
8
Years of Service
User Offline
Joined: 27th Mar 2011
Location: Gold Coast, Australia
Posted: 1st Jul 2012 05:40
@Burger
By looking at that, it looks like the medusa has no shader applied to it. Check it's "effect" section in the entity properties to see if it actually has it's shader enabled. If it doesn't have one, then try re-installing the pack. If neither of them work, then ask Bond1

-TZK

Burger
6
Years of Service
User Offline
Joined: 22nd Jun 2012
Location: New Zealand
Posted: 1st Jul 2012 12:10 Edited at: 8th Jul 2012 09:34
The effect section of medusa is set to a shader. I have reinstalled, repaired, uninstalled and redownloaded and unfortunately coming up with the same result. I'm not sure what's going wrong.

I'm inspired by my own wise quotes, thank you.

Attachments

Login to view attachments
MK83
12
Years of Service
User Offline
Joined: 10th Jun 2006
Location: Greeneville, TN
Posted: 2nd Jul 2012 05:29
mine does this too. I went back to version 1.18.

mk83 Productions
seth zer0
12
Years of Service
User Offline
Joined: 22nd Apr 2006
Location: Fort Walton Beach, FL
Posted: 14th Jul 2012 05:28
Is there a way to make the Medusa not freeze during its death. Medusa works fine until you kill it then it starts to die but freezes right after it places its hands\arms on its head and never burns. tried to fix it with bond1 burnout scripts and shader but still nothing.
TheStigg
6
Years of Service
User Offline
Joined: 20th Jul 2012
Location:
Posted: 20th Jul 2012 18:00
Hello, I recently purchased this pack and when I did, I encountered a problem. First, my FPSC program reverted to free. I fixed that, but now whenever I play my games everything looks like it does in the editor. Screenshot is attached of Decayed. I've tried uninstalling the pack and re-installing it and nothing helps. All shader effects and full graphic settings are applied. If someone knows how to help me I'd much appreciate it. I really don't want to uninstall it but if it looks like this I don't see the point in having it anymore and it'd be a waste Thank you

Attachments

Login to view attachments
seth zer0
12
Years of Service
User Offline
Joined: 22nd Apr 2006
Location: Fort Walton Beach, FL
Posted: 24th Jul 2012 23:53 Edited at: 24th Jul 2012 23:54
You have to reset up your settings. turn full shaders back on and the texture settings should be set back to how you had it as well(depends on your comp specs, but try no reduction.) and if you did any changes to your build setting/setting.ini you'll have to reset them as well. that should fix that problem

bond1
13
Years of Service
User Offline
Joined: 27th Oct 2005
Location:
Posted: 25th Jul 2012 08:23
This pack probably needs an update. It was made using v1.17 and needed a lot of workarounds in the scripts at the time, because FPSC simply didn't have the scripting commands and features that is does now.

I'll have a look, and try and get an official update for this pack.

SPECS: Intel Corei7 3770k, Nvidia GTX680, 16GB RAM, Win7 Pro
seth zer0
12
Years of Service
User Offline
Joined: 22nd Apr 2006
Location: Fort Walton Beach, FL
Posted: 25th Jul 2012 23:28
Can you also update the tgc store ones as well please.
that's where I bought Medusa.

Scurvy Lobster
13
Years of Service
User Offline
Joined: 3rd Mar 2006
Location: Denmark
Posted: 18th Aug 2012 09:25 Edited at: 20th Aug 2012 10:36
bond1: any news on an official patch for MP52?


edit: thanks for the fix F l a t l a n d e r

Nickydude
Retired Moderator
12
Years of Service
User Offline
Joined: 4th Nov 2006
Location: Look outside...
Posted: 6th Oct 2012 00:35
I've just come across this problem, thanks for the fix and any chance up an update Bond1?

I reject your reality and substitute my own...
Scurvy Lobster
13
Years of Service
User Offline
Joined: 3rd Mar 2006
Location: Denmark
Posted: 1st Feb 2013 13:40 Edited at: 1st Feb 2013 13:40
With the latest betas for V120 (I'm currently on beta 15) I cannot get the custom grendel_destroy script working anymore. It may be a ragdoll issue since it looks like the model rips appart when you kill it. Anyone else having this problem or found a new script to solve it?
Zombie_Expert
7
Years of Service
User Offline
Joined: 5th Jul 2011
Location: Raccoon City
Posted: 8th Feb 2013 02:57
Can you just make a download for the script fixes? So it's easier. Or is there an official fix from bond1?

Z_E
Flatlander
FPSC Tool Maker
12
Years of Service
User Offline
Joined: 22nd Jan 2007
Location: The Flatlands
Posted: 8th Feb 2013 05:45 Edited at: 8th Feb 2013 06:00
I haven't looked at it using v120 yet. I am using beta 15 so I'll make a test for myself. There might have been changes that have effected the custom script. We'll see.

Addendum:

I did a quick test on the three that are mentioned in original post to this thread. I used only the default appear and destroy scripts plus the custom main script.

I did not try the DAI scripts.

Works fine for me.

THEORY - you know everything but nothing works. PRACTICE - when everything works but don't know why. For me, theory and practice are combined: nothing works and I don't know why.
Scurvy Lobster
13
Years of Service
User Offline
Joined: 3rd Mar 2006
Location: Denmark
Posted: 8th Feb 2013 08:59
I just tested with stock destroy scripts too and they seem to be working fine. That is useable at least.

Problem seems to be the ragdoll effect and I can live without that when I think about it.
Kasai Shi
5
Years of Service
User Offline
Joined: 7th Apr 2013
Location:
Posted: 17th Apr 2013 15:38
These aren't working for me. When I did them exactly, they made them invulnerable. Also, I can't seem to stop the glitch where Medusa does it's full death animation. Same with Jaws and Spiky, they don't fall down randomly and come back up whenever I shoot them.

v1.19

FPS Creator
maxi360
7
Years of Service
User Offline
Joined: 26th Mar 2012
Location: Home
Posted: 6th May 2013 17:12
Thanks but seems the pitcher now lose his 1 shoot ability ( when the eyes are yellow they can die by 1 shoot)

I don't buy games....i make them.
Flatlander
FPSC Tool Maker
12
Years of Service
User Offline
Joined: 22nd Jan 2007
Location: The Flatlands
Posted: 7th May 2013 00:43
Quote: "the pitcher now . . ."


I think you mean "pincher" I thought he wasn't able to die so easy. I will look at the code again.


I'm addicted to programming and coffee!
Kasai Shi
5
Years of Service
User Offline
Joined: 7th Apr 2013
Location:
Posted: 12th May 2013 09:02 Edited at: 12th May 2013 09:04
Quote: "I think you mean "pincher" I thought he wasn't able to die so easy. I will look at the code again."


Even just checking the video you can see all of the characters functions, like the Jaws and Spikey characters are meant to fall backwards when shot randomly, and then come straight back up.

Off Topic: Oh and Flatlander, you should really check your emails. There's a Email of mine which you need to reply to. ^.^
Flatlander
FPSC Tool Maker
12
Years of Service
User Offline
Joined: 22nd Jan 2007
Location: The Flatlands
Posted: 12th May 2013 22:35
Even though you sent your emails April 30th and May 1st I didn't get them until yesterday.

I'll send you my scripts but the pincher is not working the way it should any longer; and, if my scripts don't work satisfactorily for you then there is not much more I can do.

This is not my model pack nor are they my scripts. I therefore am going to bow out with trying to accommodate everyone when they have problems. When I fixed the scripts the first time -- which was over a year ago -- they worked fine and they still work fine for me now except pincher who does not die on one shot when his eyes turn yellow. I will not work on this script until I actually am using the character.


I'm addicted to programming and coffee!
Corno_1
8
Years of Service
User Offline
Joined: 3rd Nov 2010
Location:
Posted: 12th May 2013 22:39 Edited at: 12th May 2013 22:39
Quote: "I will not work on this script until I actually am using the character."

@flatlander
I did not know if you are allowed to do, but if you are, sent me the scripts and I will look into them! maybe I can fix it!


s4real
Valued Member
12
Years of Service
User Offline
Joined: 22nd Jul 2006
Location:
Posted: 21st Jun 2013 21:42 Edited at: 21st Jun 2013 21:43
we should have all virual outbreak working correct now in the latest betas, they seem to be working as planned but im sure someone will find a bug lol

So these fixes are not needed anymore as I'm just using the normal pack without any custom scripts and they seem to be working fine at the moment.


best s4real

Pack ya games with vishnu packer its free. Vishnu game launcher is now released.
Help keep vishnu free by pledging now :- http://vishnu.chipin.com/vishnu
Flatlander
FPSC Tool Maker
12
Years of Service
User Offline
Joined: 22nd Jan 2007
Location: The Flatlands
Posted: 22nd Jun 2013 02:01
It's about time! That sounds great.


Photo by TRCox
-- The Playground is a Great Place for Happy Feet --
Tyler Smith
5
Years of Service
User Offline
Joined: 6th Aug 2013
Location:
Posted: 31st Aug 2013 08:32
I have a Problem with model pack 52 as well, but i don't know if its related if not sorry... anyway every time i try to change the creatures health, speed, or rate of fire the creature will just freeze if anyone has a solution please say so please do share thanks for your time

HI i like to make games

Login to post a reply

Server time is: 2019-03-27 03:09:09
Your offset time is: 2019-03-27 03:09:09