Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / problems with teir 1 compile ios

Author
Message
Zubby1970
AGK Backer
14
Years of Service
User Offline
Joined: 22nd May 2008
Playing: AGK Studio Always
Posted: 12th Sep 2012 18:41
apple in their wisdom had given me and update xcode will not continue with it. so i install the component updates. and then i cant compile my game to the phone. Iphone 4s

if i install xcode again it works fine but after the update it stops working again. the compile error is.

lexical or preprocessor issue.
Availabiltity.h not available.

Any ideas ?

There can only be one
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 17th Sep 2012 17:43
Which version of Xcode (4 I would think)?

Since Apple is updating the core iOS, it might be good NOT to use the updated Xcode 4. I know I had problems when they updated iOS 5. I had to make sure that my Mac Xcode and all my iOS devices all got the same updates.

Stick with the working version of Xcode. There is no rush to use all the latest Apple stuff. Not everyone is going to rush to update their devices (since that sometimes makes older stuff stop working).

Cheers,
Ancient Lady
AGK Community Tester

Login to post a reply

Server time is: 2022-10-04 14:50:33
Your offset time is: 2022-10-04 14:50:33