Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / noticed something with ios agk program...

Author
Message
sovr
12
Years of Service
User Offline
Joined: 2nd Jan 2010
Location: USA
Posted: 23rd Sep 2012 05:37
Hello, I have been working on a few apps for the iphone. When I have checked my code (which seems all correct), I execute the program to my iphone 4s (with ios6). The problem is when it trys to load the program into my iphone, which the debugger says something about that your app is universal, but there is no support for armv7s (if I am spelling it right, the 7 and s are correct)

I did look up this problem, and sources tend to point towards libraries within youe xcode project to be out of date. The solution was to set your project to a more older armv like armv6 and armv7, until the libraries are updated. Does this mean that I will have to wait for an updated version of agk? or am I completely wrong? thank you in advance... I will have the error message on the post in a little bit .

sov the game creator!
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 23rd Sep 2012 06:29
Try running it in Release mode instead of Debug. I saw someone else post a problem when doing iOS 6 in Debug mode.

If your problem disappears in Release mode, that will help us diagnose the issue.

Also, set your Xcode project to arm7 as the only valid architecture.

I was not able to load a program on my iOS 6 device (which had been iOS 5.1 and loaded fine) until I removed armv6 from the 'Valid Architectures'.

Cheers,
Ancient Lady
AGK Community Tester

Login to post a reply

Server time is: 2022-10-04 13:23:10
Your offset time is: 2022-10-04 13:23:10