Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / template_mac_xcode4 not compiling

Author
Message
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 8th May 2013 20:15
Hi all,

Im trying to run the template_mac_xcode4
but it doesn't like the My mac 64bit setup.

I can not see where i can change it, or what I
have to do to get it running.

Can you help ?


cheers
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 8th May 2013 20:48
It would help if you told us what the problem/error messages is/are.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 9th May 2013 00:57
It says:

The run destination My Mac 64–bit is not valid for Running the scheme 'template'.

The scheme 'template' contains no buildables that can be built for the SDKs supported by the run destination My Mac 64–bit. Make sure your targets all specify SDKs that are supported by this version of Xcode.
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 9th May 2013 04:28
Can I assume that you are using AppGameKit v10811?

What sort of Mac do you have? What OS version and what processor?

I just opened the v10811, updated its settings as recommended, built it and ran it and it worked fine, no complaints.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
MikeMax
AGK Academic Backer
10
Years of Service
User Offline
Joined: 13th Dec 2011
Location: Paris
Posted: 2nd Jun 2013 00:08
arg ... can't compile the MacOS Player 10812. I've tried to re-add required libraries and have updated the settings ... i have the same problem in the apps/interpreter_mac and the template :

(using XCode 4.2 on MacOS X 10.6 )

MikeMax
AGK Academic Backer
10
Years of Service
User Offline
Joined: 13th Dec 2011
Location: Paris
Posted: 2nd Jun 2013 00:09
Problem with OpenAL on my platform ? (intel coreDuo)
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 2nd Jun 2013 05:44
The problem is you are compiling in debug mode and there are no iOS/Mac debug libraries.

Switch to release mode and you should be able to compile.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
MikeMax
AGK Academic Backer
10
Years of Service
User Offline
Joined: 13th Dec 2011
Location: Paris
Posted: 2nd Jun 2013 12:33
grr yes ... the mode is in the Schemes in xcode 4.x ... was simpler in xcode 3.x ... lol

But i have a problem with OpenAL and architecture used... i have to reinstall my entire devtools i think.
MikeMax
AGK Academic Backer
10
Years of Service
User Offline
Joined: 13th Dec 2011
Location: Paris
Posted: 2nd Jun 2013 14:40
After cleaning all the frameworks in /system/libraries and unnintalling all the devtools it works after reinstall

Thanks !
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 2nd Jun 2013 17:45
Glad to help.

Happy Programming!

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master

Login to post a reply

Server time is: 2022-09-29 11:45:24
Your offset time is: 2022-09-29 11:45:24