Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / Apple Mach-O Linker Error

Author
Message
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 18th Feb 2014 21:29
Hi all,

I'm trying to get anything running with XCode5 and iOS7,
but whatever I do I get this

Apple Mach-O Linker Error
Linker comment failed with exit code 1 (use -v to see invocation)

Under Build Settings there is

Mach-O Type for Debug, Release and Simulator
with 5 possible settings

Executable
Dynamic Library
Bundle
Static Library
Relocatable Object File

but none of them works.

Can anybody help me with this ?

cheers
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 18th Feb 2014 21:38
Can you show me some screenshots of your xcode setup?

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 18th Feb 2014 22:48
How do I post screenshots ?
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 18th Feb 2014 22:57
This should work

Attachments

Login to view attachments
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 18th Feb 2014 22:58
and this too

Attachments

Login to view attachments
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 18th Feb 2014 23:00
Can you show me a shot of your project files? Click the little folder icon in the upper left and show me what's there.

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 19th Feb 2014 00:59
Oh, libAGKiphone.a is not there ?

Attachments

Login to view attachments
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 19th Feb 2014 01:02
It looks like it should be

libAGKiOS ???
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 19th Feb 2014 01:06
It's missing a lot of stuff.
Foremost it is missing links to your media folder/ You need to add your entire media folder to the project. That's what most of the complaints are about in the linker.
It should be libAGKiOS.a in the frameworks too.
You should be able to fix that in your General section for the Target.

I'll try to send you some screenshots later.

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 19th Feb 2014 01:29
Thank you sooo much Naphier.
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 19th Feb 2014 01:33

Attachments

Login to view attachments
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 19th Feb 2014 01:36
2 of 2
hope these help...
I'd almost suggest starting from the top again... something is off with the setup.
Also maybe just try the instructions in the agk online documentation. It works but it's not as detailed as AL's.

Attachments

Login to view attachments
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 19th Feb 2014 02:02
OK, I will do that.

And how do I get to the Wiki ?
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 19th Feb 2014 02:05
http://www.appgamekit.com/documentation/home.html

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 19th Feb 2014 02:44
I found it , its

http://appgamekit.wikispaces.com

cheers
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 19th Feb 2014 02:45
I'd suggest using the official game creators one that they set up. It is up to date.

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 02:47
Hi Naphier,

I just tryed to instal acording to AppGameKit online documentation
and it still does not work.

There are some odd things,

a: when I down load "AGK Windows Installer v108.21" on my Windows
machine it installs as defauld in C:\AGKTrial\.

Why Trial ???

b: then I copy AGKTrial over to my MacBook Pro and I follow
the instuctions in Guides>iOS(iPad/iPhone/iPod) and when
I get to
"Creating a project" it says "Within the AGK/IDE/templates
folder there is a folder named template_ios."

But this is not true !!!
There is no tempates in IDE.
Templates is in IDE/apps/ .

And why AGK/IDE/templates if the default is AGKTrial ?


This is where my problems start, I think.

Can anybody help ?

cheers
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 20th Feb 2014 03:11
Just downloaded AppGameKit 10821 from my products page and it has everything.
It doesn't try to install to a "AGKTrial" directory. It seems like you've got the wrong download/installation. When you download what is the name of the zip file? It should be AGK10821.zip

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 03:23
On your product page is there written
AppGameKit 10821 or do you download
AppGameKit Windows Installer v108.21 because

there is no AppGameKit 10821 on my product page.
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 20th Feb 2014 03:29
AGK Windows Installer v108.21 is what I have

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 03:47
Ok.

Then when I unzip I get
AppGameKit.exe

what I execute and the "App Game Kit V108.21 Setup"
window appears where I press "Next"

Then comes "Choose Install Location"
where it suggests

"Destination Folder"
C:\AGKTrial\



You don't get this ?
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 03:52
And when I download
"AGK Windows Installer v108.21"
I get
"AppGameKitFiles10821.zip"
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 20th Feb 2014 04:08
Yes that's the right ZIP file, sorry I misquoted before.
The deistination folder for me is
c:\program files\The Game Creators\AGK

Try a different install location. I usually use AGK10821 so I can separate the builds.
It extracted all of the templates and libraries for me.

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 04:13
Ok, I will try.

Thanks Naphier !
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 04:28
Its still the same

template_iOS is in AGK/IDE/apps/ and not in AGK/IDE/.
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 20th Feb 2014 04:30
Yes that's where they should be, sorry thought u were missing them altogether.

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 04:37
Not according to the documentation Guides for
iOS (iPad/iPhone/iPod).

Attachments

Login to view attachments
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 20th Feb 2014 04:45
You're using tier 1 basic, right?
Sounds like you're looking at the tier 2 guide.
This is the right one

http://www.appgamekit.com/documentation/guides/52_ios.htm

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 04:50
No, I'm using tier 2.
Naphier
11
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 20th Feb 2014 05:10
Ah you were posting under Ancient Lady's guide for t1 so I thought that you were using t1.
I believe the wiki you mentioned above might be your best bet. Sorry I can't help further with t2.

joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 05:15
oh, I'm sorry, thanks anyways.
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 24th Feb 2014 00:19
Also, a word about trying to build the examples. They are not necessarily up to date (especially the non-Windows ones). While TGC has been pretty good about keeping recent templates working, they have not paid much attention to doing the same with the Examples. And most of them have old AppGameKit core files and not the right libraries.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master

Login to post a reply

Server time is: 2022-09-25 22:06:49
Your offset time is: 2022-09-25 22:06:49