Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / v108.21 for iOS 7 and XCode 5

Author
Message
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 20th Feb 2014 03:13
Hi all,

I just tried to instal v108.21 according to AppGameKit online documentation and I can't make it work.

There are some odd things,

a: when I down load "AGK Windows Installer v108.21" on my Windows
machine it installs as defauld in C:\AGKTrial\.

Why Trial ???

b: then I copy AGKTrial over to my MacBook Pro and I follow
the instuctions in Guides>iOS(iPad/iPhone/iPod) and when
I get to
"Creating a project" it says "Within the AGK/IDE/templates
folder there is a folder named template_ios."

But this is not true !!!
There is no tempates in IDE.
Templates is in IDE/apps/ .

And why AGK/IDE/templates if the default is AGKTrial ?


This is where my problems start, I think.

Can anybody help ?

cheers
Markus
Valued Member
18
Years of Service
User Offline
Joined: 10th Apr 2004
Location: Germany
Posted: 23rd Feb 2014 19:17
a:
the installer shows the last used directory, just input other name.
means if i installed v21 it show me the path of v19.

b:
maybe old docu.
i had wrote a mail to the report issue mail adress in online docu.

AGK 108 (B)19 : Windows 8.1 Pro 64 Bit : AMD Radeon HD 6670
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 23rd Feb 2014 20:14
thanks Markus,

Do you use XCode 5 and iOS 7 and tier 2 ?

I'm always getting

"Apple mach-O Linker Error" and can't get out of it.

The forum for iOS is dead, nobody there.

cheers.
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 24th Feb 2014 00:53
joachim, posting the same problem in multiple threads makes it hard to see where you may have been answered or answered questions that others have asked.

I have been doing Tier 2 in Xcode since v1076. And converted to Xcode 5 when Apple forced that issue. I have not updated since v10819, so I don't know if there are any issues with the template they provided for that.

As I commented in another thread you posted about, it looks like you are trying to compile an Example project and it is not up to date at all. The image you posted here shows that it is looking for a library that does not exist in the AppGameKit build anymore (libAGKiphone.a). That may have been used in the earliest releases, but not anymore. And I can pretty much guarantee that the AppGameKit core files in the Games - Smackit project are not current with those needed for the most recent releases.

Have you tried compiling the tier 2 template without doing anything to it?

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
xGEKKOx
AGK Master
13
Years of Service
User Offline
Joined: 7th Dec 2008
Location: Italy
Posted: 25th Feb 2014 18:47
No issues, all work fine in XCode 5

Long life to Steve!

Login to post a reply

Server time is: 2022-09-25 21:25:39
Your offset time is: 2022-09-25 21:25:39