Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / pointer problem in AGK

Author
Message
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 23rd Feb 2014 23:52
Hi,

can anybody help me with this Errors ?

Please see attachment.

Attachments

Login to view attachments
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 24th Feb 2014 01:01
I don't get the same error in the v10819 template.

What compiler are you using (Project->Build Settings->Build Options->Compiler for C/C++)?

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 24th Feb 2014 02:24
Thank God you are back, I sought you left AppGameKit,
I started to panic already.
There is nobody besides you who can help, and nobody
from the TGC responds to anything, what a horrible experience.

"Compiler for C/C++/Objective-C Default compiler (Apple LLVM 5.0)"

Attachments

Login to view attachments
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 24th Feb 2014 02:28
What directory is that project in? It doesn't seem to be able to find the project files and the include files?

(I can't promise being here as much as I used to. I now have a full time job with the Alaska Railroad and have much more limited time.)

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 24th Feb 2014 02:53
Yes , I did something wrong.

I now placed the project in AGK/IDE/apps and now it
can find it , but the pointer Errors are still there.

Attachments

Login to view attachments
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 24th Feb 2014 03:02
This is what I get when I use AGK/IDE/apps/template_ios

Attachments

Login to view attachments
joachim
10
Years of Service
User Offline
Joined: 21st Feb 2012
Location: Vancouver Canada
Posted: 24th Feb 2014 03:11
Now I have the include and lib and get

Attachments

Login to view attachments
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 26th Feb 2014 03:47
What is displayed when you click on the link error in the lefthand column? It should give you some information about what it is looking for.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
xGEKKOx
AGK Master
13
Years of Service
User Offline
Joined: 7th Dec 2008
Location: Italy
Posted: 27th Feb 2014 02:13
You need to do the settings in the TARGET part not in the PROJECT!!!

Long life to Steve!
Ancient Lady
Valued Member
18
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 28th Feb 2014 04:14
Actually, you need to do it in both. But, maybe, I think the Target might default to the Project settings, if the Project settings are done first.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master

Login to post a reply

Server time is: 2022-09-25 22:49:22
Your offset time is: 2022-09-25 22:49:22