Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

FPSC Classic Scripts / Sound Not Playing

Author
Message
ApertureGFX
5
Years of Service
User Offline
Joined: 5th Mar 2014
Location: United Kingdom
Posted: 18th Mar 2014 23:27 Edited at: 19th Mar 2014 15:23
Greetings (and my apologies for posting with issues so often )

The simplest way to word this, is that the sound specified isn't playing.

Here's the script:



I've also tried manually inputting the file path, but that didn't work either. The sound is a '.wav' file. The 'MUSICVOLUME' was another approach in attempting to make it work, but that didn't help.

Does anyone have any ideas?
ncmako
7
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 20th Mar 2014 16:08
ApertureGFX
It should work. As long as you (player) enters the zone and you
added the sound in the "trigger" properties settings.
Try this if your still having problems...

Let me know
best

You know you're a bad gamer when you're able to run out of infinite lives.
ApertureGFX
5
Years of Service
User Offline
Joined: 5th Mar 2014
Location: United Kingdom
Posted: 20th Mar 2014 17:13
Ncmako,

I gave your script a try and it's still not happening. The sound is definitely in the trigger properties settings. I have been messing with the music setup in the global script if that's likely to do anything, but I've tickered with that and it's not changed anything.
ncmako
7
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 21st Mar 2014 14:45
ApertureGFX
Yes, the "music" in the setuplevel.fpi (global script) is just for
background music. Try looking again into your .wav file.
Might be saved incorrectly??? I tend to use .ogg files. They
compress better and seem to always work.
Is the .wav file your using custom, or one of the stock ones?

You know you're a bad gamer when you're able to run out of infinite lives.
ApertureGFX
5
Years of Service
User Offline
Joined: 5th Mar 2014
Location: United Kingdom
Posted: 21st Mar 2014 17:33
I'll give the OGG a try.

I've noticed it doesn't work with any of my custom sounds (hence, yes, they are custom). It might be how Adobe Audition compressess them or something.
ncmako
7
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 22nd Mar 2014 17:29
Yes it must be...try looking at one of the stock .wav files
properties and see how they are set. Go with that.
best

You know you're a bad gamer when you're able to run out of infinite lives.
BlackFox
FPSC Master
11
Years of Service
User Offline
Joined: 5th May 2008
Location: Knight to Queens Bishop 3
Posted: 22nd Mar 2014 18:58
I assume the sound is in the "/audiobank" folder? If you use the "sound=$0", it will look in the root of "audiobank". Also, check the frequency (sample rate). The materials sounds (found in /audiobank/materials) use a frequency of 22000. I recall another user had a similar issue and had to change his sample rates to get them to work.

There's no problem that can't be solved without applying a little scripting.

Login to post a reply

Server time is: 2019-09-20 16:09:55
Your offset time is: 2019-09-20 16:09:55