Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

FPSC Classic Scripts / Script for a Custom Animated Prop? Prop not playing its animation.

Author
Message
Tobias_Ripper
6
Years of Service
User Offline
Joined: 24th Mar 2013
Location: REPCONN inc.
Posted: 26th Mar 2014 18:16 Edited at: 26th Mar 2014 18:51
I have a little spook where a cardboard cutout runs across 3 FPSC cells when player goes down stairs.

The animation was made in Maya then using Bond1 Exporter in Max exported to a .x file. Using the DirectX Model Viewer, the animation shows up and the texture shows up in game as well.

However the pain in the butt for me is getting this model to play its animation of moving across the 3 cells (NOT using the paths or gravity platform, its an animation within the .x file)

Entity Script:



In Game Script:
start = apear1.fpi
main:

end: disappear1.

This is NOT a character model it is literally a prop with one single animation that is solely made to move from point A to point B. Am I setting the the Entity FPE correct? along with the Main Script

Isenstadt Studio: http://isenstadtstudio.com/
Composers Page: Milesthatch.com
Tobias_Ripper
6
Years of Service
User Offline
Joined: 24th Mar 2013
Location: REPCONN inc.
Posted: 26th Mar 2014 18:50
well few hours of searching have paid off:

Solution was found in the haystack of similar questions:
http://forum.thegamecreators.com/?m=forum_view&t=182370&b=24&msg=2170056#m2170056

Isenstadt Studio: http://isenstadtstudio.com/
Composers Page: Milesthatch.com
Avenging Eagle
14
Years of Service
User Offline
Joined: 2nd Oct 2005
Location: UK
Posted: 28th Mar 2014 10:17 Edited at: 28th Mar 2014 10:19
I'm assuming it was because you didn't specify what frames the animation took place between in the fpe?

EDIT: And then I actually read the message in your link

AE

Login to post a reply

Server time is: 2019-11-14 21:31:22
Your offset time is: 2019-11-14 21:31:22