Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

3 Dimensional Chat / TreeMagik - Demo Won't Load

Author
Message
QBert
15
Years of Service
User Offline
Joined: 3rd Dec 2007
Location:
Posted: 30th Sep 2014 15:28
Hi all. I wasn't sure where to post this since Treemagik doesn't have a forum, so I posted here.

I'm considering buying the Treemagik application but I'm having trouble getting it to load on my PC. The system is Windows 7 Professional 64-bit SP1. When I run the app, it starts a process, which I can see in my task manager, but it doesn't create a window. Interestingly enough, when I run it on my laptop (Windows 7 Professional 32-bit), it runs just fine. Sadly my laptop isn't very powerful and I'd much rather use my desktop machine.

Does anyone know if Treemagik is 64-bit compatible?

Things I have tried; running as admin, running in compatible mode (WinXP, Vista).

Thanks for any assistance.
James H
15
Years of Service
User Offline
Joined: 21st Apr 2007
Location: St Helens
Posted: 4th Oct 2014 01:18
It does not need to be 64 bit compatible, 64 bit win7 runs 32 bit apps fine, they get installed normally to program files(x86) folder I think, for the TGC apps I have they are all 32 bit and sit in this folder with the exception of Dark Shader(this has had fixes so I assume that is why as I could have sworn when I had vista it was installed in the program file(x86) folder). I have exact same version of windows as you and I am running Treemagik fine. I simply extracted the file from the zip archive, right click>properties and then check the Run as administrator checkbox and click ok, then install as normal. iirc there are 2 versions of this but the other version is not available for me to download anymore for some odd reason, the version I have now is Treemagik G3, the other version was simply called Treemagik I think, or maybe it was G2? I did not like this version at the time anyway - I suspect the same install method should be applied if you have this version.
MrValentine
AGK Backer
12
Years of Service
User Offline
Joined: 5th Dec 2010
Playing: FFVII
Posted: 4th Oct 2014 08:40
Just seeing if you get this working as I have a more advanced solution which some would rather not tell you...

James H
15
Years of Service
User Offline
Joined: 21st Apr 2007
Location: St Helens
Posted: 4th Oct 2014 22:38
Who and why? You should probably just post your advanced solution regardless of these meanies!

Another option(though not advanced solution) might be to just install it elsewhere, I prefer not to do this, I prefer installs to land where originally intended, I am reasonably sure this option would be successful as others have mentioned it works for a number of TGC products, I think GreenGandalf once mentioned the My Documents folder
James H
15
Years of Service
User Offline
Joined: 21st Apr 2007
Location: St Helens
Posted: 5th Oct 2014 05:13
Actually it only just occurred to me that the demo might act differently to the full product so I just downloaded and installed it to see, I get a small "not responding" window no matter what I do; the installed folder itself is missing parts of the installation, immediately obvious is the lack of any of the media needed with exception of the leaf painter textures!!! So is this the installer acting differently with win7 64 or is the installer lacking these files altogether? Mr Valentine this would be a good time to post your solution if its not the latter case otherwise we need to hear from someone who has the demo installed on a different OS
MrValentine
AGK Backer
12
Years of Service
User Offline
Joined: 5th Dec 2010
Playing: FFVII
Posted: 5th Oct 2014 11:16
Quote: "Who and why? You should probably just post your advanced solution regardless of these meanies!"


I grew tired of hearing the same repeat bashing nonsense that is why

http://forum.thegamecreators.com/?m=forum_view&t=159609&b=2&msg=2159408#m2159408

Link to the old post, not sure if it works for the Demo, but on Windows 8.1 Pro funny enough it [TreeMagik G3] works out of the box, but I have it installed in C:\{FOLDER not Program Files}\TreeMagik, not sure if you tried that yet, I never install in Documents folders, no idea why anybody does that... but it is up to the user... I try to keep my document folders and picture and downloads etc. as empty as possible...

Good Luck...

And thanks

James H
15
Years of Service
User Offline
Joined: 21st Apr 2007
Location: St Helens
Posted: 5th Oct 2014 20:06
Ah ok ty, tried it in c:\ and no change. Only the demo is affected - I didn`t try installing out of the box as it were for the full product as I`m now in the habit of giving admin rights to installers for TGC products so it may well work with no additional actions for the full product

I have also copied everything bar the unlock file and the exe from the full product installation across to the demo installations(I have them in several places now lol) and the problem is still apparent. As the exe`s are named differently I then copied the full products exe across to the the demo and ran it, so the only item missing now in each of the installed demos is the unlock file. It ran fine and as expected am unable to export anything. So the problem appears to be at the least specific to 64bit win7(could be other OS versions it may not work for) and it does appear that its the actual executable of the demo that has an issue along with the installer not installing all required files and folders. TGC need to look into this.

QBert
Try this - copy the entire contents of the demos directory from your 32 bit installation machine directly to the demos directory of the 64 bit installation machine and see if there is any change and let us know. Out of curiosity - providing you get it up and running that is - does it run at the same speed as your laptop? ie slowly, I`m curious as I initially noticed that the small window(the one I mentioned earlier as "not responding") does not appear immediately but takes about 10 seconds to pop up! All this aside I can at least confirm to you that the full product does work on 64bit win7 pro and also that I downloaded the product the same day as my 1st post in this thread(I have recently had to install this OS which is why I didnt have treemagik already installed), so you should be good to go if you like the product enough

Login to post a reply

Server time is: 2022-12-09 16:03:34
Your offset time is: 2022-12-09 16:03:34