Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

3 Dimensional Chat / Help with Blender (Transparent objects.)

Valued Member
Years of Service
User Offline
Joined: 27th Feb 2003
Location: The Cold North
Posted: 7th Mar 2018 17:34 Edited at: 7th Mar 2018 17:35
Hello, I'm creating a VR project and am using blender for my modelling. I have a nice pipboy crate object I made in blender but the sleeve is causing me some issues.
As in this image, with the material view selected, the sleeve is nicely transparent, you can see the text behind it. (As you should)

But when it's rendered, the sleeve blocks light so you can't see the text behind it.

Does anyone know how to resolve this? (I know that the final version will be in unity, but I want the renders of my progress so I can upload them to my website.)
If you want to see my work, you can find it here.


Login to view attachments
Years of Service
User Offline
Joined: 18th Oct 2007
Location: I`m under ur bridge eating ur goatz.
Posted: 8th Mar 2018 01:58 Edited at: 8th Mar 2018 02:00
The settings for the renderer and for the viewport are separated, so while you enabled transparency in the viewport, that won't be enough to also enable transparency for the renderer.

The setting you are looking for is under the materials tab and is called "Transparency" (you need to give the transparent object a material first):

In this scene I have a blue sphere, but it is black when inside the transparent object. If you want to see objects inside transparent objects, you need to also give those objects a material and enable the "Receive Transparent" option in the materials tab under "Shadow":

"Jeb Bush is a big fat mistake" -- Donald Trump


Login to view attachments

Login to post a reply

Server time is: 2023-09-26 10:17:13
Your offset time is: 2023-09-26 10:17:13