Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Classic Chat / google play store API update

Author
Message
smallg
Valued Member
13
Years of Service
User Offline
Joined: 8th Dec 2005
Location: steam
Posted: 12th May 2018 16:11
just a quick heads up for the next patch that google play will soon require an updated API
Quote: "From August 2018, new apps must target at least Android 8.0 (API level 26).
From November 2018, app updates must target Android 8.0 (API level 26)."
life's one big game
spec= 4ghz, 16gb ram, AMD R9 2700 gpu
Santman
7
Years of Service
User Offline
Joined: 15th Sep 2011
Location: Inverness
Posted: 12th May 2018 21:37
That doesn't sound right. How could the minimum android version be 8?? 80% of devices won't work with them.
Santman
7
Years of Service
User Offline
Joined: 15th Sep 2011
Location: Inverness
Posted: 12th May 2018 21:38
My S8+ only just recently got android 8.
fubarpk
Moderator
14
Years of Service
User Offline
Joined: 11th Jan 2005
Location: Adelaide
Posted: 12th May 2018 22:03
Quote: "That doesn't sound right. How could the minimum android version be 8?? 80% of devices won't work with them."

I thought that aswell and my phone don't have 8 installed, but think I may have to read the email I got about it again
as there may be something i've misunderstood as it might still work on some older versions with some updating to
the libraries.
fubar
smallg
Valued Member
13
Years of Service
User Offline
Joined: 8th Dec 2005
Location: steam
Posted: 12th May 2018 23:39 Edited at: 12th May 2018 23:47
that's true, i didn't really take any notice, i just copied the message i got when updating my app... but it is apparently happening
it's being stated as a security thing
Quote: "

In the second half of 2018, Play will require that new apps and app updates target a recent Android API level. This will be required for new apps in August 2018, and for updates to existing apps in November 2018. This is to ensure apps are built on the latest APIs optimized for security and performance.

In August 2019, Play will require that new apps and app updates with native libraries provide 64-bit versions in addition to their 32-bit versions.

Additionally, in early 2018, Play will start adding a small amount of security metadata on top of each APK to further verify app authenticity. You do not need to take any action for this change.
"


My mobile currently uses android 5.1 and has refused to update ever since so I guess I'll be needing to get a new phone then :p
life's one big game
spec= 4ghz, 16gb ram, AMD R9 2700 gpu
xCept
16
Years of Service
User Offline
Joined: 15th Dec 2002
Location:
Posted: 13th May 2018 00:56
To Be Clear: This change only affects the TARGET/BUILD SDK and not the MINIMUM SDK. This means that you can still set a minimum SDK to 4.x or 5.x to run on the majority of devices, it just has to be built using the latest SDK.

There is a lot of confusion including in the article that wrongly imply that all apps will soon require 8.0+ to run. That would destroy the entire Google Play economy considering fewer than 5% of all devices are on 8.0 and nearly half are still below 6.0.
smallg
Valued Member
13
Years of Service
User Offline
Joined: 8th Dec 2005
Location: steam
Posted: 13th May 2018 09:58
@xcept that makes much more sense, not really something to worry about then, I was thinking its a bit extreme but thought they might be trying to pull a windows 10
life's one big game
spec= 4ghz, 16gb ram, AMD R9 2700 gpu
Kevin Cross
15
Years of Service
User Offline
Joined: 15th Nov 2003
Location: London, UK
Posted: 17th May 2018 20:38
Do we need to update the target build/sdk or is this part of the AppGameKit package? I got the same warning just now updating an app on the Play Store.
fubarpk
Moderator
14
Years of Service
User Offline
Joined: 11th Jan 2005
Location: Adelaide
Posted: 20th May 2018 18:03
Quote: "Do we need to update the target build/sdk or is this part of the AppGameKit package? "


I think this will be an update to the AppGameKit package, plenty of time yet for them to make the changes
and im sure they would be working on it
fubar
Paul Johnston
TGC Developer
16
Years of Service
User Offline
Joined: 16th Nov 2002
Location: United Kingdom
Posted: 23rd May 2018 17:26
We are aware of this, it is an internal change and unrelated to the minimum supported version. However once the change is made it will make any apps that use commands that require permissions fail unless they specifically request those permissions with the RequestPermission command. So we're giving people time to transition. There is also a bug fix for RequestPermission for the next version so it's not quite ready yet.

Login to post a reply

Server time is: 2019-03-27 01:50:47
Your offset time is: 2019-03-27 01:50:47