Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

FPSC Classic Models and Media / Problems with custom model!!!!

Author
Message
superunixstudio
1
Years of Service
User Offline
Joined: 5th May 2018
Location:
Posted: 31st Jul 2018 11:33 Edited at: 1st Aug 2018 08:24
I downloaded scp173 model then converted it from .obj to .x, then textured it in blender next I put model in files/entitybank and texture in texturebank and it didn't even show up in fps creator menu.
PLEASE HELP!!!! IT'S VERY IMPORTANT!!!
ncmako
7
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 1st Aug 2018 11:55
Hi superunixstudio Sounds like your on the right track First look in your "Docs" folder. In there should be a .pdf named "ocfpscguide" (Official Community Guide)
It has a wealth of info on setting and importing your own custom models and more.
But to help you out, before exporting from Blender it's best to import/merge another model from fpsc ( like a table or barrel ) to get the scaling correct, then export.
Entities go into a folder inside entitybank ( files\entitybank\Name of Folder) You need 4 things to setup. 1- the .x mesh 2- a .bmp pic of the model ( 64x64 or 128x128)
3 - the .fpe file ( open another entities .fpe file and see how they are setup ) 4 - the texture itself ( 512x512 or 1024x1024) the .fpe file has a texture path that points to this file.

After this one can expand on these like extra textures for shaders and such. But if you have these 4 in place your entity should show up and be usable in fpsc.
My games never have bugs. They just develop random features..
Lots and lots of random features...

Login to post a reply

Server time is: 2019-05-21 20:45:03
Your offset time is: 2019-05-21 20:45:03