Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / ios app export problem

Author
Message
Space Dream Studios
Competition Prize Winner 2014
12
Years of Service
User Offline
Joined: 3rd Mar 2010
Location:
Posted: 7th Aug 2019 02:10 Edited at: 7th Aug 2019 08:49
When I export my app to ios and try to install it on my ipad (moving it with iTunes to the iPad), it gets a strange looking icon and it just not starts, after clicking on it.
If I install the ipa file via xcode, I'm getting following error message: "does not contain an application bundle, so it cannot be installed on"....
After installation and resetting the iPad, it now shows "Waiting...", instead of the app name and as soon as I click on the app, following message pops up: "Unable To Install...", "Please try again later."

Any ideas?

Thanks in advance!

Attachments

Login to view attachments
Space Dream Studios
Competition Prize Winner 2014
12
Years of Service
User Offline
Joined: 3rd Mar 2010
Location:
Posted: 7th Aug 2019 09:48
Am I the only one, having this issue?
Zappo
Valued Member
18
Years of Service
User Offline
Joined: 27th Oct 2004
Location: In the post
Posted: 5th Sep 2019 12:52
I am getting the same broken app icon when using an Adhoc Provisioning Profile and dragging the IPA file onto my iPhone in iTunes.
Did you find a fix for this?

Chart data provided with kind permission from ELSPA
Virtual Nomad
Moderator
16
Years of Service
User Offline
Joined: 14th Dec 2005
Location: SF Bay Area, USA
Zappo
Valued Member
18
Years of Service
User Offline
Joined: 27th Oct 2004
Location: In the post
Posted: 14th Nov 2022 12:58
I'm afraid (embarrassingly) I can't remember how I fixed this - but I did get it working.

Some things to try...
+ A generic wildcard certificate for testing adhoc apps. This will mean you can only install ONE test app at a time using that certificate, but it makes things easier than having to generate a new adhoc certificate for each new app while testing. You need to remember to uninstall the old test app that uses that same certificate before trying to install the new test app.
+ Ensure you have a valid icon for you app. I seem to remember having an issue previously with the icon that caused the installation to fail with no proper error message.
+ If you use the Admob or Chartboost libraries, remember to tick the box when exporting. This was something else I had forgotten once and it led to problems.
+ There was mention previously about version and build numbers, and app names not being validated strictly enough. I think this has long been fixed but it might be worth clearing all of those boxes in the export dialog box and retyping them to ensure no invalid values are in there.

I'm afraid I am clutching at straws really but hopefully something there might help.

Login to post a reply

Server time is: 2022-12-01 04:05:54
Your offset time is: 2022-12-01 04:05:54