Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Studio Chat / Screen artifacts when using #renderer "Basic"

Author
Message
blink0k
Moderator
7
Years of Service
User Offline
Joined: 22nd Feb 2013
Location: the land of oz
Posted: 26th Mar 2020 04:36
Screen artifacts at top left of screen when using #renderer "Basic"
SFSW
17
Years of Service
Recently Online
Joined: 9th Oct 2002
Location:
Posted: 26th Mar 2020 04:56
That (flicking font characters) looks a little like the flickering issue I ran into several months ago, which also appeared to impact text/fonts on occasion. Does this happen with every launch? Or is it intermittent? If intermittent, which exact build of AGKStudio are you using? I don't recall having this issue in either the Vulkan or OpenGL render path since the December update.
blink0k
Moderator
7
Years of Service
User Offline
Joined: 22nd Feb 2013
Location: the land of oz
Posted: 26th Mar 2020 11:53
I'm on the latest build. Happens all the time. This is specifically with #renderer "Basic". ie openGL i guess
SFSW
17
Years of Service
Recently Online
Joined: 9th Oct 2002
Location:
Posted: 26th Mar 2020 16:32
If you extract just the text code and run it on its own in a loop, does the problem go away? And if you try different vsync and FPS rates, does the behavior change?
blink0k
Moderator
7
Years of Service
User Offline
Joined: 22nd Feb 2013
Location: the land of oz
Posted: 26th Mar 2020 19:57
Quote: "If you extract just the text code and run it on its own in a loop, does the problem go away?"

Yes
I've tried to separate out some stuff but it goes away. I'll have to sit down and remove stuff bit by bit

Quote: "And if you try different vsync and FPS rates, does the behavior change?"

No
SFSW
17
Years of Service
Recently Online
Joined: 9th Oct 2002
Location:
Posted: 26th Mar 2020 20:37
Quote: "Quote: "If you extract just the text code and run it on its own in a loop, does the problem go away?"

Yes
I've tried to separate out some stuff but it goes away. I'll have to sit down and remove stuff bit by bit"


Ah ok, that does indeed sound similar to the flickering issue I'd run into before where it could change depending on what else was being rendered on the screen at the same time. So maybe the problem can still surface under certain conditions. Perhaps it's now just text related as the issue seemed solved entirely for me with textured surfaces with recent update(s).
blink0k
Moderator
7
Years of Service
User Offline
Joined: 22nd Feb 2013
Location: the land of oz
Posted: 26th Mar 2020 22:59
Yeah. When i get a chance i'll peal things away bit by bit and see if i can nail it down
basicFanatic
3
Years of Service
User Offline
Joined: 7th Jun 2017
Location:
Posted: 27th Mar 2020 18:41
Try having "something" in the background, not just emptiness.

Login to post a reply

Server time is: 2020-09-25 01:05:28
Your offset time is: 2020-09-25 01:05:28