Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DarkBASIC Discussion / The 3D Gamemaker in 2020 - Problems

Author
Message
Zombiki
User Offline
Joined: 11th Sep 2020
Location:
Posted: 11th Sep 2020 21:01
Hello,
For starters, sorry for my poor English. Well... then...
Maybe many of you will remember the old program called "The 3D Gamemaker". Yes, i know it's very old, but recently I was remembering the old years I used it. So I decided to again install the program and play with it. But the years went on and everything grew old. As a result, the program suffers from many bugs in 2020.
The biggest problem is saving the game and runtime error 9, 136, 138, 139 etc. This is because the program saves files in the folder Windows/Temp/AckGame. On 98 or XP this folder had different security and everything worked fine, but on Windows 7, 8 and 10 the security is higher and there is a problem with running saved games because the program has problems reading information and saving it in the system folder.
I realize that the program has its age, but maybe one of you could help in this matter. I would like to know if it is possible to somehow change the path to save files. The 3D Gamemaker just saves files to the Windows folder by default. I would like to know if there is any way to change this file path? So that the .exe file (game exe generated by the program) unpacks, for example, in the folder where it is located and does not try to enter the system.

If it is impossible I would like to know if there is any other option. Opening the .exe file as administrator doesn't help.
Thanks for reading!
Raven
15
Years of Service
User Offline
Joined: 23rd Mar 2005
Location: Hertfordshire, England
Posted: 22nd Oct 2020 12:55
Easiest solution is go to the C:\Windows Folder... Right-Click [Temp] > Properties > Security > Select Users (YourComputerID\Users) > Edit
Then just Allow All and hit Apply.

That will ensure that you'll always have unrestricted access, which really should be the Default Behaviour of said Directory today.
Now beyond that, you might be running into Runtime Errors not because the Directory is inaccessible but because some feature of DirectX 8.1 isn't supported via Emulation.
For that you'll need to get a copy of D3DRM.DLL and have that in the 3D Game Maker directory (where the 3dgm.exe is).

Believe it or not, just having that in the Directory actually solves like 99% of the issues for 3DGM and DBC on Windows 8.0 and above.

Attachments

Login to view attachments

Login to post a reply

Server time is: 2020-12-04 11:39:55
Your offset time is: 2020-12-04 11:39:55