Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / SetSoundInstanceBalance doesn't seem to work on Android

Author
Message
Zappo
Valued Member
18
Years of Service
User Offline
Joined: 27th Oct 2004
Location: In the post
Posted: 19th Oct 2022 14:37 Edited at: 19th Oct 2022 18:16
I'm trying to get the audio left/right balance to work on Android but the SetSoundInstanceBalance command seems to be ignored. It works perfectly on Windows and iOS but not my Android device. If I use a stereo sound file with audio in it that switches from left to right the app plays it fine and the audio switches from left to right as expected. If I use the SetSoundInstanceBalance command to force left or right it makes no difference. If I use a mono sound file the SetSoundInstanceBalance command also has no effect.

If anyone can test this out for me I will be very grateful. It is possible it is my device but all other stereo tests work fine.
Here is some quick test code which should move the sound gently from left to right and back again in a loop:



You can use your own sound sample or the attached WAV file which is mono 44.1KHz 16bit.

Thanks.
EDIT: Updated the attached sound file as the original one was far too quiet for testing.

Attachments

Login to view attachments
Zappo
Valued Member
18
Years of Service
User Offline
Joined: 27th Oct 2004
Location: In the post
Posted: 21st Oct 2022 13:39
I've managed to test this on 3 Android devices now and the problem occurs on all of them, so I have added it as a bug to GitHub:
https://github.com/TheGameCreators/AGK-Studio/issues/1029

Login to post a reply

Server time is: 2022-12-01 03:02:21
Your offset time is: 2022-12-01 03:02:21