Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Newcomers AppGameKit Corner / [Linux] AGK Help failed to launch the web browser

User Offline
Joined: 10th Feb 2023
Posted: 11th Feb 2023 03:19
Linux Platform: Pop!_OS 22.04 LTS (64 bit)
Gnome Version: 42.5

AGK Classic IDE Version: 2023.01.26

Web browsers: Firefox and Google Chrome installed from Pop!_Shop apps

Problem Description:

On a fresh installation of AppGameKit classic by Steam.

When choosing any select list (mainly web) that points to the website (eg. AppGameKit Website) cause an error dialog appears, stating "Failed to spawn the configured browser command" and requesting the user input. I view the Edit-> Preferences -> Tools -> Browser field entry as firefox. I assumed AppGameKit could not find the binary executable of firefox. I had no idea where the firefox and google web browser executable folder location was as it was installed by Pop!_Shop apps. I click on the "Folder icon button " on the Browser field, I assumed the /usr/bin/ folder would have the firefox and google browser binary but not found. I guess the AGK's folder browser cannot access admin privileges folders. Last resort I remove the firefox and google apps using the Pop!_Shop apps and AppGameKit classic software via Steam. Reinstall firefox and google chrome first then AppGameKit classic. The problem still persist.

Expected Result: A web browser launch and load the AppGamekit website content.

Steps to reproduce the problem:

1. Launch AGK
2. Click on the Help tap -> AppGamekit Website

Refer to the screenshots attachment file of the error dialog box result of the above.


Login to view attachments
Virtual Nomad
Years of Service
User Offline
Joined: 14th Dec 2005
Location: SF Bay Area, USA
Posted: 11th Feb 2023 16:27
i believe Help simply launches the appropriate html files found @ the install location: ...\Steam\steamapps\common\App Game Kit 2\Tier 1\Help which your OS opens with the default browser/application you've set for .html files (@ the OS level).

my edit>preferences>tools>browser prompt is empty so it launches with my default browser (ms edge). i browsed to iexplorer.exe on my WIN system just now (hit Apply, OK and relaunched AGK) but help still uses edge so dunno if that can be used to open help with an alternate app (i believe it did on my old WIN 7 system).

what does it do if you launch AppGameKit as Admin (or whatever equivalent on Linux)? are you launching from Steam or directly from the install location?

frankly, if you can use AppGameKit and Run/F5 properly launches the app then i dont think it's a permission thing but really don't know.

User Offline
Joined: 10th Feb 2023
Posted: 12th Feb 2023 13:51
Purchase AppGameKit Classic from Steam. Yes, I'm launching AppGameKit from Steam.

I tried the other option you suggested to execute the AGK64 from admin/sudo via the terminal and from the installed location.

1. Open the terminal on the folder that contains the AGK64 binary
2. At the prompt; $ sudo ./AGK64
3. Provide the sudo account password
4. AppGameKit launch
5. Click on the Help tap -> AppGamekit Website

The problem still persists with the same error message.

Note: AGK64 file location found using the Steam AppGameKit Launch button. Right-click on the Steam AppGameKit Launch button -> Properties -> LOCAL FILES -> Browse.
Valued Member
Years of Service
User Offline
Joined: 27th Oct 2004
Location: In the post
Posted: 13th Feb 2023 14:41
I'm not familiar with Pop!_OS but it sounds like there might not be a default program associated with html files, or the association is broken/conflicted.

Something you could try...
Locate the help files for AppGameKit Studio - which are usually in the "media/help" directory. Double click on the home.html file to see if it opens up in a default web browser. If it works then I am out of suggestions. If it doesn't work then it will be a file association problem. There is mention online of removing the xdg-utils package and reinstalling it as that seems to include xdg-open that is used to open URLs and web pages in the users preferred web browser. To do that, you would type:
sudo apt-get remove xdg-utils
sudo apt-get install xdg-utils

I have never had to do this so I can't say if it will work with local files or not (or what damage reinstalling it might do), but it seems to have fixed URL links for other people.
User Offline
Joined: 10th Feb 2023
Posted: 14th Feb 2023 14:32
Located the home.html file

1. Close all the web browser apps
2. Open the file manager and select the folder containing home.html file
3. Double-Click on the home.html file
4. Google Chrome Browser URL open as file:///home/shankuo/.var/app/com.valvesoftware.Steam/.local/share/Steam/steamapps/common/App%20Game%20Kit%202/Tier1/Help/home.html

Confirmed no file association problem with web browsers.

I tried AppGameKit Classic on the MacOS Catalina (10.15.7) it did not have this problem

I have purchased the AppGameKit Studio 2023.01.25 and installed it on Pop! OS, I don't have this problem. I guess stopping using the AppGameKit Classic until the AppGameKit team of developers fixes this problem or stick with AppGameKit Studio apps completely.

Login to post a reply

Server time is: 2023-12-08 06:55:58
Your offset time is: 2023-12-08 06:55:58