Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark GDK / Still having problems

Author
Message
Dragonslayer
19
Years of Service
User Offline
Joined: 4th Nov 2003
Location: New Lenox Illinois U.S.A.
Posted: 14th Dec 2004 05:49
I have gone through the posts reinstalled DX9 the oct update and the extras file and have installed them, the only thing I could set up in V6 in the extras folder was some lib files and there is a dll in there do I need to put that someplace. Here is the error I get

--------------------Configuration: Main - Win32 Debug--------------------
Linking...
Creating library Debug/Main.lib and object Debug/Main.exp
LINK : warning LNK4098: defaultlib "LIBC" conflicts with use of other libs; use /NODEFAULTLIB:library
LIBCD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main
Debug/Main.exe : fatal error LNK1120: 1 unresolved externals
Error executing link.exe.

Main.exe - 2 error(s), 1 warning(s)

My options panel looks like
INCLUDE
DX9SDK\INCLUDE
DGSDK\INCLUDE
VC98\INCLUDE
VC98MFC\INCLUDE
VCALT\INCLUDE

LIB
OCT2004 EXTRAS\LIB
DXSDK\LIB
DGSDK\LIB
VSTUDIO\VC98\LIB
VSTUDIO\VC98MFC\LIB

anyone got any answers? I'm itching to get this running. aits probably something dumb on my part but I have been working on this all day and now my eyes are crossed

Dragonslayer
Mike Johnson
TGC Developer
20
Years of Service
User Offline
Joined: 13th Sep 2002
Location: United Kingdom
Posted: 14th Dec 2004 05:55
It sounds like you might have attempted to create a console style application. You need to use a standard Win32 project or because you're using VS6 you can use the wizard to start a new application. In VS6 go to "file->new", now select the "projects" tab. Look in the list and click on "Dark Game SDK AppWizard". Now on the right side of the dialog type in a project name and select the location for the files. When you have done that press the ok button. Now you will get an application set up for you that contains all of the settings you need. Look at the file "main.cpp" and you can see code for a simple loop. Try compiling this application.

Have you been able to compile any of the sample programs?

Mike
MiR
19
Years of Service
User Offline
Joined: 13th Jul 2003
Location: Spain
Posted: 14th Dec 2004 05:56
Try sending. the DGSDK lib and include to the top of the list. I heard it´s position in the list decides how it works. Not that it can help much. My version stopped working and I had the lib and include files at the top


A bargain at 900000€ second hand
Libera tu mente y te liberaras.
Dragonslayer
19
Years of Service
User Offline
Joined: 4th Nov 2003
Location: New Lenox Illinois U.S.A.
Posted: 14th Dec 2004 06:02
I tried putting DGSDK at the top but I did not start a project I just opened the example file and then tried to build it and the compiler set up a defult project so I will try what mike posted be back soon with results!!! Also Mike I have tried most of the samples the same way.

Dragonslayer
Dragonslayer
19
Years of Service
User Offline
Joined: 4th Nov 2003
Location: New Lenox Illinois U.S.A.
Posted: 14th Dec 2004 06:14
Ok I got it to build the project and I get a Dark Game screen up but the program does not run the screen is just black. I get no errors but I get this warning.

--------------------Configuration: test2 - Win32 Debug--------------------
Compiling resources...
Compiling...
Main.cpp
Linking...
Creating library Debug/test2.lib and object Debug/test2.exp
LINK : warning LNK4098: defaultlib "LIBC" conflicts with use of other libs; use /NODEFAULTLIB:library

test2.exe - 0 error(s), 1 warning(s)

Dragonslayer
Mike Johnson
TGC Developer
20
Years of Service
User Offline
Joined: 13th Sep 2002
Location: United Kingdom
Posted: 14th Dec 2004 06:17
That's all working right Nothing is included in the wizard - all it does it set up a loop for you.

Try using this code in main.cpp -



Mike
Dragonslayer
19
Years of Service
User Offline
Joined: 4th Nov 2003
Location: New Lenox Illinois U.S.A.
Posted: 14th Dec 2004 06:37
That worked But I'm still getting warnings herehthey are,

--------------------Configuration: test - Win32 Debug--------------------
Compiling resources...
Compiling...
Main.cpp
e:\dark game sdk\projects\test\main.cpp(17) : warning C4244: 'argument' : conversion from 'double' to 'float', possible loss of data
e:\dark game sdk\projects\test\main.cpp(17) : warning C4244: 'argument' : conversion from 'double' to 'float', possible loss of data
e:\dark game sdk\projects\test\main.cpp(17) : warning C4244: 'argument' : conversion from 'double' to 'float', possible loss of data
Linking...
Creating library Debug/test.lib and object Debug/test.exp
LINK : warning LNK4098: defaultlib "LIBC" conflicts with use of other libs; use /NODEFAULTLIB:library

test.exe - 0 error(s), 4 warning(s)

I think the double to float warning may be because the .1 in the rotate statement but I did not see a double declared, I'm not really up on c++ but the linking warning is what I want to know about!

Dragonslayer
IanM
Retired Moderator
20
Years of Service
User Offline
Joined: 11th Sep 2002
Location: In my moon base
Posted: 14th Dec 2004 06:40
Switching to release mode will remove the LINK warning.

For various ways to remove the conversion warnings, read the FAQ post (my way is the better way BTW )

*** Coming soon - Network Plug-in - Check my site for info ***
For free Plug-ins and source code http://www.matrix1.demon.co.uk
Dragonslayer
19
Years of Service
User Offline
Joined: 4th Nov 2003
Location: New Lenox Illinois U.S.A.
Posted: 14th Dec 2004 06:46
Ok I will do that, like I said my c++ skills need lots of work whrer do I switch to release mode?
Dragonslayer
19
Years of Service
User Offline
Joined: 4th Nov 2003
Location: New Lenox Illinois U.S.A.
Posted: 14th Dec 2004 06:50
well I found where to switch the modes and I had no conversion or link warnings when I rebuilt the project so I'm off to play, thanks to everyone for your help!!!!

Dragonslayer
IanM
Retired Moderator
20
Years of Service
User Offline
Joined: 11th Sep 2002
Location: In my moon base
Posted: 14th Dec 2004 06:52
If you are using .NET or 2003, it's a drop-down option on the toolbar. Just select Release instead of Debug.

If you have VC++6, then select menu options Build->Select active Configuration, and then select the release build in the window that appears.

This is the reason I included two builds with my interface lib, one debug, one release ... are you listening Mike?

*** Coming soon - Network Plug-in - Check my site for info ***
For free Plug-ins and source code http://www.matrix1.demon.co.uk

Login to post a reply

Server time is: 2023-02-05 20:22:01
Your offset time is: 2023-02-05 20:22:01