Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark GDK / Cannot Open d3dx9.lib

Author
Message
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 26th Jul 2005 00:36 Edited at: 26th Jul 2005 00:37
Edit: Change that to d3dx8.lib

Im getting that error message when I try to compile and run a program, but I have the directories all set up correctly. Any ideas?

Formerly The Fixxer
http://www.xiemsoft.cjb.net
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 26th Jul 2005 00:40
Ahh Ive just discovered that I do not have the d3dx8.lib
But why should I need it is DGSDK uses dx9?

Formerly The Fixxer
http://www.xiemsoft.cjb.net
OSX Using Happy Dude
19
Years of Service
User Offline
Joined: 21st Aug 2003
Location: At home
Posted: 26th Jul 2005 01:07
Because DirectX 9 also has interfaces to DX8 and I thinm 7 as well.

AtomZ - its got an A. Its got a Z. Now its just needs U
Blog:http://spaces.msn.com/members/BouncyBrick/
Web Site:http://www.nicholaskingsley.co.uk
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 26th Jul 2005 01:09
Ahh I think it maybe because im using the december edition of the DX SDK? I read in the bug thread that i need to use the october one. Ill try that.

Formerly The Fixxer
http://www.xiemsoft.cjb.net
OSX Using Happy Dude
19
Years of Service
User Offline
Joined: 21st Aug 2003
Location: At home
Posted: 26th Jul 2005 01:30
Are you using VS6 ? If so, I believe October or maybe December is the last SDK that can be used.

AtomZ - its got an A. Its got a Z. Now its just needs U
Blog:http://spaces.msn.com/members/BouncyBrick/
Web Site:http://www.nicholaskingsley.co.uk
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 26th Jul 2005 02:05
Yea VC++ 6.0
I removed the December SDK and installed the October one and got 93 errors??? Right now im re-installing the december update.

Formerly The Fixxer
http://www.xiemsoft.cjb.net
OSX Using Happy Dude
19
Years of Service
User Offline
Joined: 21st Aug 2003
Location: At home
Posted: 26th Jul 2005 03:28
Did you set all the paths up correctly ?

AtomZ - its got an A. Its got a Z. Now its just needs U
Blog:http://spaces.msn.com/members/BouncyBrick/
Web Site:http://www.nicholaskingsley.co.uk
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 26th Jul 2005 12:18
i think so, im going directly to the x86 folder.

Formerly The Fixxer
http://www.xiemsoft.cjb.net
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 26th Jul 2005 13:25 Edited at: 26th Jul 2005 13:25
This is everything in the folder that I linked to.



Formerly The Fixxer
http://www.xiemsoft.cjb.net
OSX Using Happy Dude
19
Years of Service
User Offline
Joined: 21st Aug 2003
Location: At home
Posted: 26th Jul 2005 16:38
And headers?

AtomZ - its got an A. Its got a Z. Now its just needs U
Blog:http://spaces.msn.com/members/BouncyBrick/
Web Site:http://www.nicholaskingsley.co.uk
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 27th Jul 2005 01:17
the headers are fine, its the lib that I dont have for some reason.

Formerly The Fixxer
http://www.xiemsoft.cjb.net
OSX Using Happy Dude
19
Years of Service
User Offline
Joined: 21st Aug 2003
Location: At home
Posted: 27th Jul 2005 01:41
With VS6 you'll probably need the extras pack. Unfortunately as I dont use VS6, I cant really help further, surfice to say :

Make sure headers & libraries are correct and they appear before the DarkSDK ones.

AtomZ - its got an A. Its got a Z. Now its just needs U
Blog:http://spaces.msn.com/members/BouncyBrick/
Web Site:http://www.nicholaskingsley.co.uk
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 27th Jul 2005 01:42
ty

Formerly The Fixxer
http://www.xiemsoft.cjb.net
OSX Using Happy Dude
19
Years of Service
User Offline
Joined: 21st Aug 2003
Location: At home
Posted: 27th Jul 2005 01:46
No doubt some others will be able to continue from here...

AtomZ - its got an A. Its got a Z. Now its just needs U
Blog:http://spaces.msn.com/members/BouncyBrick/
Web Site:http://www.nicholaskingsley.co.uk
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 27th Jul 2005 02:00
hopefully soon.

Formerly The Fixxer
http://www.xiemsoft.cjb.net
matt rochon
19
Years of Service
User Offline
Joined: 15th Mar 2003
Location: Canada
Posted: 27th Jul 2005 02:57
i use vc6, i needed to download the extras pack from december if im not mistaken, i know theres a post about it on the forums here
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 27th Jul 2005 03:38
I downloaded the february extras cause im using the feb edition of the sdk now, and it didnt come with the lib file im missing.

Formerly The Fixxer
http://www.xiemsoft.cjb.net
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 27th Jul 2005 03:42
Are there any specifications on what I should be using? Im downloading the sdks, and they appear to be incomplete

Anyone know if im doing something wrong? Starting from scratch with no SDK, what should I be downloading? I only downloaded the dec and feb sdks, is that all I need or do I need a main sdk?

Formerly The Fixxer
http://www.xiemsoft.cjb.net
Mike Johnson
TGC Developer
20
Years of Service
User Offline
Joined: 13th Sep 2002
Location: United Kingdom
Posted: 27th Jul 2005 04:36 Edited at: 27th Jul 2005 04:37
You will have to use one of the earlier DirectX 9 SDKs that is compatible with Visual C++ 6.0.

Try getting the SDK from October 2004 http://www.microsoft.com/downloads/details.aspx?familyid=B7BC31FA-2DF1-44FD-95A4-C2555446AED4&displaylang=en.
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 27th Jul 2005 04:52 Edited at: 27th Jul 2005 04:53
I tried the october one earlier and got 93 errors instead of the 1 link error. Ill try again. Also, I used the December SDK when I was learning how to use direct draw and it worked just fine, so the december sdk is also compatible, but im also getting the same link error.

Formerly The Fixxer
http://www.xiemsoft.cjb.net
Artus
17
Years of Service
User Offline
Joined: 25th Feb 2005
Location: France
Posted: 27th Jul 2005 05:11 Edited at: 27th Jul 2005 05:14
I also use VC6.

- Install October DirectX SDK update
- Download October extras.
- from folder Extras\D3dx9 Visual Studio 6
-> Copy d3dx9d.dll and d3dx9d.pdb in c:\windows\system32
-> Copy d3d*.lib in c:\Program Files\Microsoft DirectX 9.0 SDK (October 2004)\Lib

For me, it works fine without having to change anything in VC6 configuration.
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 27th Jul 2005 05:13
ill try that, im downloading the october sdk now

Formerly The Fixxer
http://www.xiemsoft.cjb.net
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 27th Jul 2005 05:28
i dont quite understand what you mean after download october extras. Here are the new errors with the october sdk.



Formerly The Fixxer
http://www.xiemsoft.cjb.net
Mike Johnson
TGC Developer
20
Years of Service
User Offline
Joined: 13th Sep 2002
Location: United Kingdom
Posted: 27th Jul 2005 05:36
There's info in this thread explaining about this problem and how it was solved http://forum.thegamecreators.com/?m=forum_view&t=43921&b=22
Briere
17
Years of Service
User Offline
Joined: 28th Feb 2005
Location: Amherst New York, United States
Posted: 27th Jul 2005 05:58
thanks, its working now

Formerly The Fixxer
http://www.xiemsoft.cjb.net

Login to post a reply

Server time is: 2023-02-02 14:31:41
Your offset time is: 2023-02-02 14:31:41