Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark Physics & Dark A.I. & Dark Dynamix / Either a Bug or Something I'm doing Wrong - Won't save file for static rigid body static terrain?

Author
Message
Airslide
19
Years of Service
User Offline
Joined: 18th Oct 2004
Location: California
Posted: 20th Dec 2006 01:07 Edited at: 20th Dec 2006 03:15
Okay, when I try phy make rigid body static terrain and use the file$ paramater, no file seems to be saved. I tried using Get Dir$()+"export folder" but it doesn't seem to help Is there a special extension or anything I need to know, or is this a bug?

Codger
21
Years of Service
User Offline
Joined: 23rd Nov 2002
Location:
Posted: 20th Dec 2006 02:55
Quote: "phy make static rigid body static terrain "


do you mean
phy make rigid body static terrain ID, file$

you have too many static's in your example

System
PIV 2.8 MZ 512 Mem
FX 5600 256 mem
Airslide
19
Years of Service
User Offline
Joined: 18th Oct 2004
Location: California
Posted: 20th Dec 2006 03:14 Edited at: 20th Dec 2006 03:36
Right, I wrote the command wrong (didn't want to bother getting out the manual for spell checking) I'll fix that now. Anyone know why the file isn't exported?

EDIT: I'm updating my PhyX Drivers, maybe that will help.

EDIT 2: Nope. No luck. This is seriously increasing the loading time of my levels, does anybody have any ideas/know how to get it to work?

JerBil
19
Years of Service
User Offline
Joined: 8th May 2004
Location: Somewhere along the Z axis...
Posted: 20th Dec 2006 16:25
Forgive me, but you are using a file name?
I think you can make up any name and extension you wish.
In the example "LandA.scp" is the file name and Scape is the
terrain number.
The file should be in the same directory run in, in this case.
After the first run to save, rem out the save line and the second
line should load your terrain.

To save:
phy make rigid body static terrain Scape,"LandA.scp"

To Load:
phy load rigid body static terrain Scape,"LandA.scp"

Ad Astra Per Asper
Airslide
19
Years of Service
User Offline
Joined: 18th Oct 2004
Location: California
Posted: 20th Dec 2006 22:19 Edited at: 20th Dec 2006 23:17
Yep, I used a file name - I seem to be missing all to many things from my posts recently

I'll try messing with it somemore, tell you guys If I can make it work...

EDIT: Nope. When I did as you said, once I ran it the second time it just crashed. Ugg...

EDIT 2: Now I got it working! I used the extension '.phy', though it could also do with the fact that I had forgot I needed to re-upgrade darkphysics (first time around I put in the wrong reg code and had to uninstall everything, including the update, in order to get it to work)

Alfred
17
Years of Service
User Offline
Joined: 22nd Jun 2006
Location: Jalisco, Mexico
Posted: 23rd Dec 2006 18:47 Edited at: 23rd Dec 2006 18:55
When I save PhysX data files ( be it terrains, meshes, convex meshes) I find that sometimes the program saves the files and sometimes it doesn´t. This is when using "*.dat ; *.scp ; *.data ; *.mesh ; *.etc " extensions, but when I use the "*.phy" extension it always saves. I am not really sure if there is something else going on in my code or not, but for the time being I will stick with "*.phy". That´s all I have tested until now.

Edit: Apparently the missing file mystery was something on my computer. Just tested again and all extensions save ok.

Hallowed are the ori.

Login to post a reply

Server time is: 2024-02-25 16:01:07
Your offset time is: 2024-02-25 16:01:07