That shouldn't cause any issues, however I think there is a better way to accomplish what you want.
int FreeObject( )
{
int i = 1;
while ( dbObjectExist( i ) )
{
i += 1;
}
return i;
}
Stick that in your code somewhere, and whenever you want to create an object, do something like this:
int ObjectID = FreeObject( );
dbLoadObject( "Object.x", ObjectID );
It's much cleaner and ensures that you use every object number available to you ( There are a finite number ). Plus, it's far more readable to refer to your objects with actual names rather than numbers. 'PlayerModelID' is quite a bit more descriptive than say...'2452'