Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

FPSC Classic Models and Media / [SOLVED] Milkshape to FPSC help.

Author
Message
TMoney Moterbike Dude
4
Years of Service
User Offline
Joined: 15th May 2016
Location:
Posted: 5th May 2020 21:43 Edited at: 5th May 2020 21:52
OK so this is kind of a long explanation. I don't really know where to put this but I think this is more of an FPSC problem than modeling problem. Anyway, I recently bought Milkshape to edit so characters and make my own models for my game. I've spent the past week figuring out how to edit animations, and after a while I edited the bikini character from Model Pack 4 to appear to be surrendering in her crouch animation. I exported to FPSC but I only got the stock animations (with bond1s animations as well.) I looked around the forums and followed this guide https://forum.thegamecreators.com/thread/81224 and was able to get the animations to work. However, now my character only appears as a black model. I've taken away the texture file and it changes to a white texture-less model. I've changed the texture to a .tga from a .dds and vice versa as well as changing it to a .bmp, to no avail. I don't really know what to do anymore. I have edited animations before but it wasn't the animation itself, it was really just stuff like characters idle is a crouch or stuff like that. The character has a black texture both in the editor and in the game. I do have multiple versions of the bikini girl (variations of the characters texture), but this particular one was in their own folder with all the files, and before I changed the animations, worked like any other character. The two screen shots help show the problem. I'm trying this on FPS Creator V1.20 with shadders off, medium lighting and medium textures, if that's important at all. Like I said, I followed everything in the link.
EDIT:
I'm sorry if this is against the rules because a similar problem has been answered. If so I'll delete this post.
Logo by The Next

Attachments

Login to view attachments

The author of this post has marked a post as an answer.

Go to answer

ncmako
8
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 6th May 2020 11:27
TMoney I thought Milkshape couldn't import .x files? Or did you convert it to .obj?
If you did that may be a problem. Are you using the JT exporter?
** WHERE'S MY DARN YELLOW BUTTON ? **
TMoney Moterbike Dude
4
Years of Service
User Offline
Joined: 15th May 2016
Location:
Posted: 6th May 2020 14:12 Edited at: 6th May 2020 14:14
Yes I am using the JT exporter. The screenshots included show the model that I have edited the animations to, except the model is all black. As I've said I followed this guide here: https://forum.thegamecreators.com/thread/81224 to get the model have the custom animations, but I can't get the texture to appear.
EDIT: Also, what I did was export the .x from Fragmotion to .ms3d, then exported the .ms3d to .x after I made the modifications.
Logo by The Next
starmind 001
FPSC Reloaded Backer
12
Years of Service
User Offline
Joined: 23rd Sep 2007
Location:
Posted: 6th May 2020 16:28
This post has been marked by the post author as the answer.
Quote: "except the model is all black"

Bring your model back into fragmotion and see if it is missing the texture. If it is missing, apply the texture and export it back to fpsc. If you really want to see what is happening import the .dbo into fragmotion and it will show if it had the texture or not. Then make a new character entity as to not override the original and make sure the texture path is correct.
One last thing or should be the first thing, always use the cleaner. Unlike current game engines, fpsc doesn't take to kindly to adding new stuff or updating old stuff. If you don't use the cleaner everytime, textures go black, pink and even white.
Enjoy!

PS: Use blender 2.49 or later instead of milkshape. Edits are easier.
https://i.vgy.me/aWPGmv.png
TMoney Moterbike Dude
4
Years of Service
User Offline
Joined: 15th May 2016
Location:
Posted: 6th May 2020 17:43
Thankyou so much. I'll give that a try.
Logo by The Next
TMoney Moterbike Dude
4
Years of Service
User Offline
Joined: 15th May 2016
Location:
Posted: 7th May 2020 15:09
Double Post:
It works! Thank you both for the help! I was able to get the model to work after I put it through entity maker after applying the texture in fragmotion and low and behold the character is textured now! Thank you both!
Logo by The Next
starmind 001
FPSC Reloaded Backer
12
Years of Service
User Offline
Joined: 23rd Sep 2007
Location:
Posted: 8th May 2020 21:53
Quote: "It works! "

Glad to hear!
https://i.vgy.me/aWPGmv.png
RJ is out Leave a message
14
Years of Service
User Offline
Joined: 7th Nov 2005
Location: The butt end of the U.S.
Posted: 10th Jun 2020 14:14
Hi there. I can't seem to find ANY direct x exporter for the latest version of Blender nor can I find an exporter for Fragmotion. Anybody know where a direct download link is?
ncmako
8
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 10th Jun 2020 23:47
@ RJ Fragmotion should have an .x exporter already built in? Under file\export then save as choose .x format
** WHERE'S MY eXplosys ? **

Login to post a reply

Server time is: 2020-08-13 19:07:21
Your offset time is: 2020-08-13 19:07:21